Getting Started With BPM - Best Practices
Legal Notices

Warranty
The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.
The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor’s standard commercial license.

Copyright Notice
© Copyright 2005 - 2015 Hewlett-Packard Development Company, L.P.

Trademark Notices
Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.
AMD and the AMD Arrow symbol are trademarks of Advanced Micro Devices, Inc.
Google™ and Google Maps™ are trademarks of Google Inc.
Intel®, Itanium®, Pentium®, and Intel® Xeon® are trademarks of Intel Corporation in the U.S. and other countries.
IPod is a trademark of Apple Computer, Inc.
Java is a registered trademark of Oracle and/or its affiliates.
Microsoft®, Windows®, Windows NT®, Windows® XP, and Windows Vista® are U.S. registered trademarks of Microsoft Corporation.
Oracle is a registered trademark of Oracle Corporation and/or its affiliates.
UNIX® is a registered trademark of The Open Group.
Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.
Intel®, Pentium®, and Intel® Xeon® are trademarks of Intel Corporation in the U.S. and other countries.
IPod is a trademark of Apple Computer, Inc.
Java is a registered trademark of Oracle and/or its affiliates.
Microsoft®, Windows®, Windows NT®, and Windows® XP are U.S registered trademarks of Microsoft Corporation.
Oracle is a registered trademark of Oracle Corporation and/or its affiliates.
UNIX® is a registered trademark of The Open Group.

Documentation Updates
The title page of this document contains the following identifying information:

- Software Version number, which indicates the software version.
- Document Release Date, which changes each time the document is updated.
- Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to: https://softwaresupport.hp.com/group/softwaresupport/search-result?keyword=

This site requires an HP Passport account. If you do not have one, click the Create an account button on the HP Passport Sign in page.

Support
Visit the HP Software Support web site at: https://softwaresupport.hp.com
This web site provides contact information and details about the products, services, and support that HP Software offers.
HP Software Support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage your business. As a valued support customer, you can benefit by using the support web site to:

- Search for knowledge documents of interest
- Submit and track support cases and enhancement requests
- Download software patches
- Manage support contracts
- Look up HP support contacts
- Review information about available services
- Enter into discussions with other software customers
- Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support contract. To register for an HP Passport ID, go to https://softwaresupport.hp.com and click Register.

To find more information about access levels, go to: https://softwaresupport.hp.com/web/softwaresupport/access-levels

**HP Software Integrations, Solutions and Best Practices**

Visit the Integrations and Solutions Catalog at https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01702710 to explore how the products in the HP Software catalog work together, exchange information, and solve business needs.

Contents

Chapter 1: Introduction ................................................................. 5
  Scope and Motivation .............................................................. 5
  Why Use BPM? ................................................................. 5

Chapter 2: Installing BPM .............................................................. 6

Chapter 3: Connecting BPM to BSM .............................................. 14

Chapter 4: Creating Scripts in TruClient and Defining Transactions .......... 16

Chapter 5: Creating Business Applications .................................... 22

Chapter 6: Configuring Alerts ....................................................... 26

Chapter 7: Configuring Transaction Thresholds ............................... 31

Chapter 8: Viewing Data in BSM .................................................. 33
  Viewing Data in Service Health .............................................. 33
  Viewing Data in BPM Performance Over Time Report .................. 33
  Viewing Data in Scheduled Reports ..................................... 34

Chapter 9: BPM Report Recommendation .................................... 41

Send Documentation Feedback .................................................. 43
Chapter 1: Introduction

This section introduces the Getting Started With BPM - Best Practices and includes the following topics:

- "Scope and Motivation" below
- "Why Use BPM?" below

Scope and Motivation

Business Process Monitor (BPM) is one of the HP Business Service Management (Business Service Management) data collectors. BPM proactively monitors enterprise applications in real time, identifying performance and availability problems before users experience them. It enables you to monitor sites from various locations, emulating the end-user experience, and so assess site performance from different client perspectives.

The purpose of this document is to provide BPM users with an understanding of how to deploy BPM quickly and correctly, and how to realize value in a short time.

The target audience for this guide is customers who are new implementers of BPM, or HP partners who already have Business Service Management (Business Service Management) knowledge, but are new to BPM. While no deep networking/encryption knowledge is needed, you will need to know the protocol and encryption used by the monitored application.

Why Use BPM?

BPM should be used to gather data during inactive hours of the users, so you will be able to detect problems before a real user encounters them. In addition, BPM is the basic monitor for building SLAs, because it has the same transaction monitored at the same time intervals.
Chapter 2: Installing BPM

The following provides instructions for installing BPM.

Before beginning the installation, verify that you have Java version 1.7 or above installed on your computer. If not, download the most recent Java version from the Java website.

1. Download your BPM from the HP Software Support Online web site (http://www.hp.com/go/hpsoftwaresupport). Go to Software Support Online > Downloads > Software Patches and select Application Performance Management as the product. For each version, check for Business Process Monitor as a sub-product.

2. Save the file under: C:\Temp.


4. In the first screen, select your language and click OK.

5. In the Introduction screen, read the introduction text and click Next.
6. In the Product Agreement screen, accept the license agreement and click Next.

7. In the Product Customization screen, accept the defaults folders or browse to and select the application and data folders and click Next.
8. In the Product Requirements screen, verify that there is enough disk space for the installation and click Next.

9. In the Pre-Install Summary screen, verify that the application and data folder paths are correct and
click **Install**.

The Installing screen appears.
The BPM Configuration wizard is automatically launched after the setup program installed the BPM application.

10. In the Run as User screen of the BPM Configuration Wizard, configure the BPM data collection to run as a system user, or as a specific user. Running it as a specific user limits access to resources, settings, and applications located on the local machine. (This may not be true for resources located on remote machines, where a specific user may have different privileges than the local system user.)

11. In the Server Authentication screen, select Use basic authentication and enter your BSM user name and password in case your Business Service Management gateway access is protected by user name
12. In the Instance Definition screen, select **Define Instance** and type your BSM details. The Location name is used for script assignment, so give it a meaningful name (for example, New York, Office).
13. When the Finish screen appears, click **Close**.

![Finish screen](image)


![Business Process Monitor](image)

15. Verify that your instance connected successfully by checking the Health value in the General Information page.
Chapter 3: Connecting BPM to BSM

1. From your internet browser, access http://localhost:2696/. The BPM application appears.

2. Click the create new instance button. The Create New Instance Wizard appears.

3. In the Define Identification Parameters screen, define the identification parameters for the new instance. All fields are mandatory. Make sure you can access the Gateway Server URL from the BPM machine. The Location name is used for script assignment, so give it a meaningful name (for example, Boston, Office).

4. Click Finish.

5. Refresh your browser and verify that BPM successfully connected to your BSM.
6. If your Gateway Server URL is not accessible from your BPM machine, or if you need a proxy, an error message appears. If this occurs, click the **Configuration** tab, reconfigure the details, and click **Save**.

If you successfully connected, the following status appears.
Chapter 4: Creating Scripts in TruClient and Defining Transactions

**Note:** If you are using script services from other team members or companies, you can download the Business Process Template for BPM Scripting Requests from the HP Software Support site ([http://www.hp.com/go/hpsoftwaresupport](http://www.hp.com/go/hpsoftwaresupport)) to define your script requirements.

1. Download and install VuGen from your DVD.
2. Click **File > New Script and Solution**.
3. Select the relevant protocol. For a web application, select **TruClient Ajax Firefox**.
4. Click the Develop Script button to start your recording. A Firefox window appears.
5. Click the red circle button to start your recording.
6. In the Firefox address bar, type the address of your web application. Each action you perform is indicated by a recording event in the TruClient add-in.

7. After you finish recording your business transaction, open the Transaction Editor, and wrap the relevant action in the transaction name. Make sure that you define a start point and end point for
each transaction, and click **Apply**.

8. In the Transaction Editor, click the plus icon to add more transactions.
9. After defining your transactions, save your script.

11. In the Vugen Editor, select File > Manage Zip Files > Export Zip Files to export your script to a zip file.
12. To be able to view and edit the script, select **All files**, and click **OK**.

13. Since the script size can be huge, export another copy of the script and select **Runtime only** and upload this copy to Business Service Management.
Chapter 5: Creating Business Applications

1. Select Admin > End User Administration > Monitoring.

2. Right-click End User Management (default view) and select Add > Application and its BPM Configuration.

3. In the Default Transaction Settings screen, define your transaction settings for performance monitoring.

   **Note:** You can wait to define these settings after you determine your application's expected behavior.
4. In the Set Transaction Monitor Scripts screen, click **Script Repository** to view the scripts in the repository.
5. To select a script, double-click the script in the Available Scripts tree.

6. In the Application Data Collectors screen, click \( \mathbb{C} \).

7. In the Add Data Collectors screen, assign the data collectors to a location.
8. In the Application Data Collectors screen, edit the schedule for each location, or leave the default value (every 15 minutes).

9. After reviewing your settings, click Finish and your script will start to run. I can take up to 20 minutes to see the first data point, depending on BPM's scheduled jobs.

10. Please continue from here with our setting started to see how to view BPM data in BSM.
1. In the Monitoring tab, select your application.

2. Click the Alerts tab in the right pane.

3. Click the Trigger Condition tab.
4. In the **Alert name** field, type a meaningful name for the alert. In Outlook, you will be able to filter your alerts by this name.

   **Note:** The contents of the **Severity** field is for internal use. The trigger criteria is set according to the number of locations you have, and the frequency of the monitor runs. If you have four locations around the word, and if two subsequent runs fail, then a real problem alert is indicated and false alerts are ignored.

5. Click the **Filters** tab.
6. Select the relevant transactions by which to filter the alert.

7. Click the **Actions** tab.
8. Select the **Send to specified recipients** option.

9. Click the **Advanced Settings** tab.

10. To send an alert when the trigger condition clears, click the **Send clear (follow up) alert notification** option.
11. To limit the number of alerts that are sent, click the **Send no more than one alert for every** option and enter the time period.
Chapter 7: Configuring Transaction Thresholds

In BSM there are three methods for setting performance transaction thresholds:

- **Manual** – Provides full control of the transaction thresholds

- **Semi-automatic** – Utilizes the Calculate Suggested Thresholds tool which provides static thresholds based on a specific time period.

- **Automatic** – Provides automatic threshold baselines

In order to get accurate results, take into account that each location has different thresholds. You can set a different threshold for each transaction location.

To create threshold baselines for Business Process Monitor, you first need to activate a general key to enable this feature. Then you adapt the thresholds for each application. We recommend that you create the thresholds one at a time in order to ensure that the results are accurate. You can then add the results to your best practices.
For more information, see the Business Process Monitor Administration Guide which is available for download from the HP Software Support site: http://support.openview.hp.com/selfsolve/manuals.
Chapter 8: Viewing Data in BSM

You can view your monitored application data by accessing the 360° View in System Health or by running the BPM Performance Over Time report.

Viewing Data in Service Health

The BPM checks if there is a new configuration every 2 minutes. If you schedule your script to run an application every 15 minutes, the first data point arrives within 17 minutes.

If a script fails, a red icon appears near the relevant transaction CI, You need to fix the script, and upload it again.

1. In BSM, click Application > Service Health > 360° View.
2. In the Name column, click the application to expand it. The latest monitored data is displayed.

Viewing Data in BPM Performance Over Time Report

You can view your data in the BPM Performance Over Time report. This is one of the most important reports for BPM monitoring. The BPM Performance Over Time report displays a flat view of the data for all your BPM applications and transactions.

1. In BSM, click Applications > Analysis Reports > BPM Performance Over Time.
2. In the Application Filter, select your application.
3. Click Run.

4. To verify that all your BPMs are reporting, in the Group by field, select Location. The report displays our BPM data and you can determine if all you BPMs are reporting data as expected.

5. To view an advanced report that summarizes all data collection problems, in BSM, click Applications > Utilities > BPM Self Monitoring. The BPM Self Monitoring report displays valuable information about your BPM health based on the data that is expected to arrive.

Viewing Data in Scheduled Reports

You can configure schedules to enable specified recipients to automatically receive reports, through email, at regularly defined intervals.
You can schedule Custom Reports, Trend Reports, and Service Reports defined in the Report Manager, or reports saved from the specific report page. You can also schedule Favorite Filter reports.

1. **To create a scheduled report,** click **Applications > User Reports > Report Manager.**

   This page enables you to manage the contents of Report Manager and view, edit, and clone existing components, configure new user reports, email reports, and create a schedule for selected reports to run.

2. **Click and select New Custom Report** to create your first report using the built-in BSM reports.

3. **If you want to run this report in the background,** select the **Refresh the report every** option and select the number of minutes.
4. Click **Next**.

5. In the **Report Components** page, click the **+**. The **Add Component** page appears.

6. All BPM report are located in the **End User Management** folder.
7. Expand the contents of the **End User Management** folder and click **Status Reports**.
8. From the Report drop down list, select **BPM Performance Overtime By Transaction**.

9. Click **OK**.

10. In the **Report Components** page, click . The **Add Component** page appears.

11. Under the **End User Management** folder, click **Analysis Reports**.

12. From the Report drop down list, select **Metrics Over Time** for a report that displays over time measurements.

13. Click **OK**.

14. For each report, select the report and click the **Edit Filter** button.
15. Select the relevant application.
Chapter 9: BPM Report Recommendation

Use the following reports for isolating problems:

- **Performance Over Time Report**

  You can view your application availability and performance in one report. You can select to view the data by transaction or by location over time. By clicking on a specific transaction or location, you can view the Error Log, Snapshot on Error, Transaction Breakdown, and Error vs Availability Over Timer in the same screen.

  In BSM, select **Applications > End User Management > Analysis Reports > BPM Performance Over Time**.

- **Triage Report**

  Data in the Triage report is organized by transactions and locations, and includes a transaction breakdown component, as well as graphs showing error data. This report also includes information about the health of the transaction scripts running at the various locations (Script Health), as well as indicators for the health of the BPM data collectors.

  In BSM, select **Applications > End User Management > Analysis Reports > Triage Report**.
Metrics Report

This report enables you to select one or more metrics for selected applications and to view their behavior over a period of time. By selecting multiple metrics, you can compare their behavior to discover possible correlations between them. You can also view data for up to four different time comparisons.

In BSM, select Applications > End User Management > Analysis Reports > Metrics Over Time.
Send Documentation Feedback

If you have comments about this document, you can contact the documentation team by email. If an email client is configured on this system, click the link above and an email window opens with the following information in the subject line:

Feedback on Getting Started With BPM - Best Practices (Business Service Management 9.26)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client, and send your feedback to Sw-doc@hp.com.

We appreciate your feedback!